Die Entwicklung von phlyMail ist eingestellt. Wir empfehlen Ihnen, so bald wie möglich auf alternative Produkte zu wechseln.
The development of phlyMail has been stopped. Please change to alternative products as soon as possible

System Requirements Webserver

Minimum Requirements

  • PHP 5.4
    • „Safe Mode“ disabled
    • „Register Globals“ disabled
    • „Magic Quotes“ disabled
    • Directive „Open Basedir“ set correctly
    • Session management active and configured correctly
    • Extensions iconv or mbstring available
    • Sockets available
    • File Uploads are enabled
    • Extensions GD or ImageMagick installed and configured
    • MySQL support via one of the extensions mysqli (recommended), mysql or PDO
    • memory_limit and max_execution_time as well as post_max_size and upload_max_filesize are set to sensibly high values
    • Sendmail or SMTP available (recommended: SMTP)
    • JSON support available
    • OpenSSL extension (for using SSL / TLS in conjunction with POP3, IMAP, SMTP, UMS Gateway)
    • Extensions PCNTL and POSIX are installed
  • MySQL 5.5 (or comparable MariaDB)
    • Storage engine InnoDB available and set as default
    • Default charset / collation UTF-8 (e.g. utf8_general_ci)
    • phlyMail needs the following permissions on its own database: SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER
    • Target database and the database user needs to be set up before installation and be activated through GRANT or FLUSH PRIVILEGES
  • Webserver capable of PHP (e.g. Apache)
  • Unblocked communication with the relevant ports is possible, especially with the ports for SMTP, HTTP, POP3, IMAP and their SSL variants
  • File and folder permissions and ownership are setup correctly before running the installation script
  • Linux or other UN*Xoid OS; Microsoft® Windows® only in conjunction with Apache as the webserver.
  • Sufficient RAM, CPU power and hard disc space are available
  • Please note, that the optional Expire plugin is not compatible with Microsoft® Windows®

Recommended Settings / Extensions

  • PHP
    • We recommend to always use the latest stable version, right now this is PHP 7
    • disable_classes / disable_functions are empty / unset
    • allow_url_fopen = On
    • zlib extension (for AutoUpdate service)
    • bzip2 extension (for AutoUpdate service)
    • PECL extension „setproctitle“ for PHP version < 5.5.0
    • the Hash extension is not disabled
    • PEAR module „Auth/Yubico“ for two-factor logins with a Yubikey
  • MySQL 5.6.4 or newer to use the fulltext search feature for emails
  • You should be able to run Cron jobs (browser based services will no longer work as of phlyMail 4.4!)
  • We recommend using Apache 2.4 with PHP as module (mod_php)
  • At least 512MBs of RAM, more is strongly recommended
  • At least a single core CPU with 1 GHz, a multi core CPU is strongly recommended, especially when running larger installations with many active users
  • The required hard disc space strongly adheres to the usage profile of your users. Switching from POP3 to IMAP eases the burden on the web server. Keeping many, large files in the files manager may quickly consume much space on disc.
  • To use two-factor auth through SMS you should grant your users a sensible amount of SMS per months and always have enough deposit in your messaging account.
Last update on this list: November 2016

Requirements Web Browser (Desktop)

phlyMail's interface demands for high capabilites of the browser used, since many things like sensible context menus and the calendar view are currently only possible via JavaScript. That's why the browser must be capable of the following things:

  • JavaScript 1.5, DOM 2.0
  • iframes
  • CSS (inklusive CSS3)
  • XHTML / HTML5
  • UTF-8
  • AJAX (XMLHTTPRequest)
  • Flash (for MP3 player and notification sounds)
  • Alternativly the HTML5 tag <audio>

That's why we recommend to always use a modern, up-to-date brwoser like Chrome, Safari or Firefox.
Although it's slowly catching up, Internet Explorer is still not our first choice. Most of the frontend should work well enough in IE9+, though.

Requirements Web Browser (Mobile)

For the mobile interface we chose the Open Source library jQuery Mobile. This ensures a broad support for a large amount of mobile terminal, steady development and high quality of the software.
Already now the sheer bandwidth of supported mobile operating systems is quasi exhaustive. The only requirement is a somewhat modern and capable msart phone or tablet, which has a sufficiently large, touch sensitive display.
The "simple" mobile interface also recommends itself for older browsers, slow Desktop machines or those with smaller displays like Netbooks.

For a detailed, up-to-date list we would like to point you to the project's page, which also states the grade of support for specific OSs and browsers.

Here we have a short, exemplary list of mobile operating systems with excellent support:

  • Apple iOS 3.2 – 10.0
  • Android 2.1 – 6.0
  • Windows Phone 7-8
  • Blackberry 6.0, 7, Playbook
  • Palm WebOS 1.4 – 3.0
  • Meego 1.2
  • Samsung bada 2.0
Last update on this list: November 2016
Please wait